Products Resources Support About Us

Rocket Software

zOS git clone https://... fails helper not found git 2.14.4

Clone from https fails with

Cloning into …
warning: templates not found /var/rocket/git/share/git-core/templates
fatal: Unable to find remote helper for ‘https’

I believe 2.14.4 provides support for https.

Hi ianc,

Are curl and openssl installed on your system?
Can you also add here output of following command “env | sort”

Thanks,
Alex

We have:-

OpenSSL 1.0.2k 26 Jan 2017
curl 7.66.0 (i370-ibm-openedition) libcurl/7.66.0 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.18.1

env | sort output as follows…

DBB_HOME=/usr/lpp/IBM/dbb
GIT_EXEC_PATH=/var/rocket/git/libexec/git-core
GIT_MAN_PATH=/var/rocket/git/man
GIT_SHELL=/var/rocket/git/bin/bash
GIT_TEMPLATE_DIR=/var/rocket/git/share/git-core/templates
JAVA_HOME=/usr/lpp/java/J8.0_64
LANG=C
LIBPATH=/var/rocket/git/lib/perl5/5.24.0/os390/CORE:/lib:/usr/lib:.:/var/rocket/lib/perl5/5.24.0/os390/CORE
MANPATH=/var/rocket/git/man:/usr/man/%L:/var/rocket/man/:/var/rocket/ported/man/
NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat
NODE_HOME=/usr/lpp/IBM/cnj/IBM/node-latest-os390-s390x
OLDPWD=/var/zowe/builds/imsplugin
PATH=/var/rocket/git/bin:.:/bin:/usr/lpp/java/J8.0_64/bin:/u/home/ianc/zospt/bin:/usr/lpp/IBM/cnj/IBM/node-latest-os390-s390x/bin:/usr/lpp/IBM/cnj/njsc/bin:/usr/lpp/cobol/bin:/var/rocket/bin:/var/rocket/ported/bin
PERL5LIB=/var/rocket/git/lib/perl5
PS1=$LOGNAME:$PWD: >
RSUSR=/var/rocket/git
SHELL=/bin/sh
SHLVL=1
SSH_TTY=/dev/ttyp0000
STEPLIB=none
ZOWE_EXPLORER_HOST=xxxxxxxx
ZOWE_IPADDRESS=nn.nn.nn.nn
ZOWE_JAVA_HOME=/usr/lpp/java/J8.0_64
ZOWE_ZOSMF_PATH=/var/zosmf/configuration/servers/zosmfServer/
ZOWE_ZOSMF_PORT=nnnn
_=/bin/env
_BPXK_AUTOCVT=ON
_CEE_RUNOPTS=FILETAG(AUTOCVT,AUTOTAG) POSIX(ON)
_TAG_REDIR_ERR=txt
_TAG_REDIR_IN=txt
_TAG_REDIR_OUT=txt

Hi ianc,

Not sure it’s the reason of your problem, but as I see you shell is sh
SHELL=/bin/sh
Can you add to your .profile following strings:
SHELL=/var/rocket/git/bin/bash
exec $SHELL
(if it’s right path to your bash)
Btw, as you have “warning: templates not found /var/rocket/git/share/git-core/templates” can you also give us output of the following command : “ls -laTR /var/rocket/git”
And one more thing: which version and build of git do you have?
git --version

Thanks,
Alexander

Hi,

Git-2.14.4 supports HTTPS.

The error ‘fatal: Unable to find remote helper for ‘https’’ occurs when GIT_EXEC_PATH is not set correctly.
The warning ‘warning: templates not found /var/rocket/git/share/git-core/templates’ occurs when GIT_TEMPLATE_DIR is not set correctly.

Probably, these variables unset before running git commands.

If you are using DBB, for example, please check if they are properly set in gitenv.sh