Products Resources Support About Us

Rocket Software

Vim shows garbage

Hi all, I have installed vim along with bash, gzip, git.
I have followed all the READMEs (at least I think so) and everything is apparently working, but vim shows a strange behavior: every time I start it, the first line shows garbage characters. As soon as I scroll, the garbage disappears and the real text appears.
Unfortunately, new files or files which only contain one line cannot be scrolled, so I cannot see the first line.
Hints?

Thank you in advance!
Cris

Chris,
Do you have env variables TERMINFO and/or TERM set to anything? Unfortunate settings here could make vim choke.

This is what I have now:

SIGDC@BVLSYSB [~/test]$ env|grep -i term
TERM=xterm-256color
TERMINFO=/bkd/share/terminfo

but even plain xterm gives the problem.

Try to unset TERMINFO. Perhaps this interferes.

unset TERMINFO

Did not make a difference, unfortunately:

Just to make sure. I guess you have all the env var inplace which are required by vim

 export _BPXK_AUTOCVT="ON"
 export _TAG_REDIR_ERR="txt"
 export _TAG_REDIR_OUT="txt"
 export _TAG_REDIR_IN="txt"
 export _CEE_RUNOPTS="FILETAG(AUTOCVT,AUTOTAG) POSIX(ON)"
 export VIM="${TGTDIR}/share/vim/vim80"
 export PATH="${TGTDIR}/bin:$PATH"

where TGTDIR is the installation directory of vim

1 Like

Hi Manfred,
this is what I have in my /etc/profile:

# ======================================================================
# Impostazioni per git e altri port della Rocket Software
# ======================================================================
export PATH=/bkd/bin:$PATH
export MANPATH=$MANPATH:/bkd/man
export INFOPATH=$INFOPATH:/bkd/info
export CHARSETALIASDIR=/bkd/lib
export GIT_SHELL=/bkd/bin/bash
export GIT_EXEC_PATH=/bkd/libexec/git-core
export GIT_TEMPLATE_DIR=/bkd/share/git-core/templates
export GIT_MAN_PATH=/bkd/man
export PERL5LIB=/bkd/share/perl/5.24.1:/bkd/lib/perl5
export LIBPATH=$LIBPATH:/bkd/lib/perl5/5.24.0/os390/CORE
export _BPXK_AUTOCVT=ON
export _CEE_RUNOPTS="FILETAG(AUTOCVT,AUTOTAG) POSIX(ON)"
export _TAG_REDIR_ERR=txt
export _TAG_REDIR_IN=txt
export _TAG_REDIR_OUT=txt
export TERMINFO=/bkd/share/terminfo
export VIM=/bkd/share/vim/
git config --global core.editor /bkd/bin/vim
git config --global core.pager /bin/more

I changed the VIM variable to:

VIM=/bkd/share/vim/vim80

but that, again, made no difference.

Cris

I have also tried three different terminal emulators:

  • remmina (SSH connection)
  • konsole
  • EasySSH

All three show garbage characters upon opening vim.

I did one more test with MobaXTerm, and it seems it shows no garbage.
So it would seem that the problem is in the terminal emulator, even though I am quite surprised that three out of four show the problem.
Do you have suggestions on more tests to do to identify what exactly is the problem?

This all is strange, and I have to admit that I have not understood fully these terminal issues regarding vim. For instance, I have a problem to get colors in vim although on a different systems (same settings) there are colors.

Here, running Linux (i.e. Fedora 31), I ssh-connect using xfce4-terminal or mate-terminal. Both working fine.

Perhaps the Rocket people have ideas to help.

Thank you @ManfredLotz for all the help so far.
Let’s hope that someone from Rocket Software will take a look at this thread.

Try to append the following line to .vimrc:

set t_RV=

and restart vim. I hope this will help.
Regards.

1 Like

@msviridov it worked!! Thank you!!
What does this option do? I did not find documentation.

TIA
Cris

Cris70, see http://vimdoc.sourceforge.net/htmldoc/term.html#t_RV