Products Resources Support About Us

Rocket Software

Unable to run pip3

Hello,

We’re trying to get pip3 and aws cli working and we’re encountering this error:

$ pip3 --trusted-host xxx install -v --log ./pip3verbose.log --index-url https://xxx/repository/pypi-all/simple awscli --upgrade --use>

ÈÇ?: pip3 1: FSUM7351 not found

“–ø: pip3 1: FSUM7351 not found

ÈÇ?: pip3 1: FSUM7351 not found

pip3 1: FSUM7343 cannot open “/%_/Ñ” for output: EDC5129I No such file or directory.

pip3 1: FSUM7343 cannot open “€Ñ_ø?ÊÈ€_/Ñ” for output: EDC5129I No such file or directory.

pip3 1: FSUM7343 cannot open “/Á^^€€^/Ñ” for output: EDC5129I No such file or directory.

pip3 1: syntax error: got ), expecting Newline

We’ve set BPXK_AUTOCVT to ON

Any ideas on how to start troubleshooting this?

Hi jplumey,

Make sure you type env name correctly:_BPXK_AUTOCVT=ON
export _BPXK_AUTOCVT=ON
Can you also provide output of the following commands here.
pip3 --version
which pip
env|sort
Thanks,
Alex

Thanks for replying. Here’s what I have:

$ pip3 --version

ÈÇ?: pip3 1: FSUM7351 not found

“–ø: pip3 1: FSUM7351 not found

ÈÇ?: pip3 1: FSUM7351 not found

pip3 1: FSUM7343 cannot open "/%_/Ñ" for output: EDC5129I No such file or directory.

pip3 1: FSUM7343 cannot open "€Ñ_ø?ÊÈ€_/Ñ" for output: EDC5129I No such file or directory.

pip3 1: FSUM7343 cannot open "/_Á^^€€^_/Ñ" for output: EDC5129I No such file or directory.

pip3 1: syntax error: got ), expecting Newline

$ whence pip

/products/python/python-2017-04-12-py36/python36/bin/pip

$ env|sort

CURL_CA_BUNDLE=/products/python/python-2017-04-12-py36/python36/etc/ssl/cacert.pem

ENV=/etc/setup

FFI_LIB=/products/python/python-2017-04-12-py36/python36/lib/ffi

HOME=/home/$3025

HOMEMSG=Your home directory is /home/$3025

JAVA_DUMP_TDUMP_PATTERN=JVMDUMP.&SYSNAME..D&LYYMMDD..T&LHHMMSS..&JOBNAME

JAVA_HOME=/java/dflt/

LANG=C

LIBPATH=/products/python/python-2017-04-12-py36/python36/lib:/lib:/usr/lib:.:/products/perl/lib/perl5/5.24.0/os390/CORE

LOGNAME=$3025

MAIL=/usr/mail/$3025

MANPATH=/usr/man/%L:/usr/lpp/ported/man/C:/products/perl/man:/products/bash/man:/products/python/python-2017-04-12-py36/python36

NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat

PATH=/java/dflt/bin:/products/python/python-2017-04-12-py36/python36/bin:/bin:.:/products/gzip/bin:.:/products/perl/bin:/products/bash/bin::/products/python/python-2017-04-12-py36/python36/bin

PERL5LIB=:/products/perl/lib/perl5

PKG_CONFIG_PATH=/products/python/python-2017-04-12-py36/python36/lib/pkgconfig:/products/python/python-2017-04-12-py36/python36/share/pkg

PYTHON_ENV=python36

PYTHON_HOME=/products/python/python-2017-04-12-py36/python36

RELEASE_DIR=/products/python/python-2017-04-12-py36

RELEASE_NAME=python-2017-04-12

RELEASE_TYPE=py36

SHELL=/bin/sh

SSH_AUTH_SOCK=/tmp/ssh-vtjjQhA8jE/agent.16911953

SSH_CLIENT=10.32.115.10 51858 22

SSH_CONNECTION=1xxxx

SSH_TTY=/dev/ttyp0001

TCPIP_DATA=//dsn:SYS1.TCPPARMS(TCPDATA)

TERM=vt100

TERMINFO=/products/python/python-2017-04-12-py36/python36/share/terminfo

TMOUT=1800

TZ=EST5EDT

USER=$3025

_=/bin/env

_BPXK_AUTOCVT=ON

_BPXK_SETIBMOPT_TRANSPORT=TCPIP

_BPX_SPAWN_SCRIPT=YES

_C89_CLIB_PREFIX=SYS1.CBC

_CC_CLIB_PREFIX=SYS1.CBC

_CEE_RUNOPTS=FILETAG(AUTOCVT,AUTOTAG) POSIX(ON)

_CXX_CLIB_PREFIX=SYS1.CBC

_TAG_REDIR_ERR=TXT

_TAG_REDIR_IN=TXT

_TAG_REDIR_OUT=TXT

ddn_CTRANS=//dsn:xxx.VENDSASC

Please run this command:

export _BPXK_AUTOCVT=ON

and try again.

We also recommend that you put this file in your shell initialization file.

regards,

Rick Harris

Hi,

I see that already a part of the output above:

...
_=/bin/env

_BPXK_AUTOCVT=ON

_BPXK_SETIBMOPT_TRANSPORT=TCPIP
...

Please check following:


Is it possible what you update pip before this error occurs?

Chances are good that the “pip3” script is not tagged.

Please do a : ls -lT bin/pip3

first. Then do: chtag -t -c 819 bin/pip3

Or do: autotag -v bin/pip3

The autotag program scans each file to see if it is encoding in ascii or encdic, then it tags accordingly.

regards,

Rick

Our sysadmins reverted their install and pip3 now works. Thanks for the help. The end goal is to install AWS CLI, which was giving us errors, and our attempts to fix it broke pip3. I’ll create a separate issue on AWS CLI if we have problems. If you have any tips in that regard I’d love to hear them.