Products Resources Support About Us

SQL Sever 2016 - U2 64-bit ODBC Driver

unidata

#1

Greetings,

I’m having some issues with SQL Server 2016 and the 64-bit Unidata ODBC driver. We have an application that uses a Unidata 7.3 backend. We also have a separate interface to that application that utilizes ODBC connections to Unidata for its function. The ODBC connection resides on a SQL Server 2008R2 instance currently. I’m in the process of moving the ODBC connection to a SQL Sever 2016 instance.

While I’ve been able to get the connection to pass tests and while it does work, it doesn’t work reliably. If I try to excute two OPENQUERY statements successively, they’ll both fail every time. If I query one at a time and wait long enough between executions they usually complete. I’m only returning one row.

I’ve tried multiple ODBC drivers from the Rocket website, and all of them exhibit the same behavior. I’m currently using the “U2 64-Bit ODBC Driver 7.241.00.8100”. This is the error message I get when executing the statements.

Executing both statements at the same time.

select top 1 * from OPENQUERY(avante, ‘select * from INVTRAIL_NF’)
select top 1 * from OPENQUERY(avante, ‘select * from INVTRAIL_NF’)

This is what is returned.

Msg 7399, Level 16, State 1, Line 9
The OLE DB provider “MSDASQL” for linked server “avante” reported an error. Provider caused a server fault in an external process.
Msg 7303, Level 16, State 1, Line 9
Cannot initialize the data source object of OLE DB provider “MSDASQL” for linked server “avante”.

I have tried everything I found online, much of the results were more related to SQL Server rather than Unidata. I set up a SQL Server 2014 instance and Unidata 8.1. I was able to query through the same ODBC driver without issues. But when switching to the SQL Server 2016 instance, I receive the error above on every execution. I was unable to find any reported issues with SQL Server 2016 and the ODBC driver. I’m hoping either someone has encountered something similar or knows of a compatibility issue. Thank you all in advance.

  • Justin

#2

Hi Justin,

I work in Rocket support. Our support for SQL Server 2016 Linked Servers actually began at a hotfix release of the U2 Clients. I see you are using build 8100, which does not contain SQL Server 2016 support. You’ll need to download/request at least build 8101 of the U2 Clients, though I would suggest build 8102 for another U2ODBC fix we have out.

This should show up as ‘5.1.0.8102’ if you search controlled releases from our product matrix. I would suggest opening a support case if you need further assistance with this.

Regards,
Michael Belme


#3

Hello Michael,

Great, thank you for the information. I’ll give that a shot and see how that changes the performance with the ODBC driver on our SQL Server 2016 instance. I appreciate the help.

  • Justin

#4

hi , I am also trying to create Linked Server in SQL 2016 to unidata 8.1.2 using the latest odbc driver. when I test the DSN with the ODBC U"ODBC tester64 it all works. here is the properties of the linked server:

EXEC master.dbo.sp_addlinkedserver @server = N’AVANTE’, @srvproduct=N’Microsoft OLE DB Provider for ODBC Drivers’, @provider=N’MSDASQL’, @datasrc=N’LIVE_odbc’, @provstr=N’UID=user;PWD=#####‘
EXEC master.dbo.sp_addlinkedsrvlogin @rmtsrvname=N’AVANTE’,@useself=N’False’,@locallogin=NULL,@rmtuser=N’odbc’,@rmtpassword=’######

all works ok on SQL 2005, but I cannot get it to work for SQL 2016.

Any help much appreciated.


#5

@GrahamForbes To my knowledge the ODBC driver still has issues with SQL 2016. I wasn’t able to get it to connect consistently to my 2016 instance as well. We’ve been in contact with software support and we still have an open ticket in for the issue but have not seen any progress on it as of late.


#6

Thanks very much Justin

Are you using an early version of the odbc driver which works with unidata 812?


#7

I tried multiple drivers from their site. Some made it worse, the others just exhibited the same intermittent connectivity to the database. I was in contact with their support and they had me download and install a brand new installation trial of 8.2.1 and the client driver to go with it and I still had the same issues connecting via SQL 2016. We’ve since changed our focus on other tasks until they’re able to resolve the issues with the driver.


#8

I practically felt like I wrote what you both were experiencing. I am experiencing same/similar problems. Any updates on resolution, hints on joining in on a open case, or keeping an eye out on this issue for when working driver is released?


#9

I wish I had some good news for you. We had a case in with Epicor that supports the Avante solution we use, but they didn’t have any resolution after speaking with Rocket. So far we’ve not seen any progress toward a resolution. You can try the build matrix and try the newest driver to see if they patched it yet, depending on what version of UniData you’re on.

https://rbc.rocketsoftware.com/buildmatrix.asp


#10

Thank you! I’ll open a ticket with Epicor, too (we use Manage 2000) so at least they’ll know the number of people affected is going up…
If I find a work around, I’ll post.


#11

I just noticed the new interest in this topic, I will review cases, discuss this with Engineering, and put an update to this site.

Mike Rajkowski


#12

While I am not sure I found the case(s) opened from those of you on this forum, I did find more information.

The latest version of U2 Clients on WINDOWS is 5.1.0.8105

In the above readme it states:
UCC-3511
Beginning at this release, U2 ODBC supports linked servers in SQL Server 2016.

Note that while this was fixed in for 5.1.0.8101, I would recommend that you try the latest release.

If you are still having a problem, and open a support case, please let the TSE (Technical Support Engineer) know you posted a question on the Forum, so they can help close the loop.

Mike Rajkowski