Products Resources Support About Us

Rocket Software

Latest release of scikit-learn package


currently Python 3.6.1 comes with the package scikit-learn release 0.18.2. Unfortunately it does not support everything we need.
At this point I am wondering if there are any plans to port newer release of scikit-learn - 0.19.2.

Thank you,


Have you tried updating the package with pip?

Note that “pip install sklearn” should update the package if it is not the latest version.

If you are still having issues, you may need to upgrade pip.

Just tried and got errors:

$ pip install sklearn
import: pip 4: FSUM7351 not found
import: pip 5: FSUM7351 not found
from: pip 7: FSUM7351 not found
pip 10: FSUM7332 syntax error: got (, expecting then

How do I upgrade pip?

You can try:
python -m pip install --upgrade pip

Yet I am not sure if that is your issue.

Based on the FSUM7351 I think you are not finding some of the commands:
“Explanation: You attempted to execute a command that could not be found
User Response: Ensure that the command exists and that the PATH
environment variable is valid.”

Also see: Pip does not work post installation

Yes, this is right - pip (or any other packages for that matter) cannot be installed (updated) from the common repository and that’s why updated pip failed to launch. I suspect nobody has put z/OS executable to the repository.

So my question to Python porting team stays - are there any plans to port newer versions of scikit-learn package?