Products Resources Support About Us

In a Register to Download Loop for Bash 4.2.53

bash

#1

I have registered to download bash but when I get the email it has the following verbiage instead of a download link. Any ideas?
Best regards,
Javier Chavez

Get your Downloads
Thank you for submitting your request to access Rocket z/OS Open
Source Tools. Please click on the links below to access the tools. If
you have any download problems, please visit the forum for z/OS Open Source page and search for your topic.

Download , or access all z/OS Open Source Tools.
Support
For installation and general help, visit the Rocket Software forum for z/OS Open Source tools. For information on purchasing priority enterprise support for z/OS Open Source Tools, visit our pricing page.

Rocket Software

77 Fourth Avenue

Waltham, MA 02451

USA

+1 781 577 4321

www.rocketsoftware.com

info@rocketsoftware.com

sales@rocketsoftware.com

This email was sent to cjavier@us.ibm.com | Unsubscribe from all Rocket marketing communications | Manage your email preferences
© 1990-2016 Rocket Software, Inc. (Rocket). Rocket©, Rocket logos and
product names are registered trademarks or trademarks of Rocket
Software, Inc. and/or its subsidiaries. Other names and logos cited
herein are the property of their respective owners.


#2

Very sorry for this problem. It is happening since we upgraded some software in the mail delivery system. There is a workaround however.

  • Fill out the download form in any language
  • When you get the email, first switch the language in the browser that submitted the form to English for our site (language switcher is globe image in top right hand corner).
  • Click on the link in the email (or copy and past if not default browser) and you should be able to download any of the tools.
  • Switch back to language of choice.
  • You have seven days to download more tools but will need to switch back to English before clicking on the link again if you want to do more downloads.

Downloading Rocket z/OS Open Source Languages and Tools
#3

Thank you. I tried a different browser today (after trying the workaround
four times with no success) and this time the email had a link to the file
of the tool I needed. That was not the case with the other browser so I am
not sure what control is preventing your site from seeing which tool I had
selected for download. Thanks again for all your help.


#4

Still can’t access any z/OS Open Source Language and Tool products. Registered, received the confirmation e-mail with customized link, clicked on link, taken to the Languages tab of the Ported Tools page, clicked on the Python 2.7.6 download… and I am then taken immediately back to the registration page. Tried this on the most recent versions of Firefox, IE, and Chrome, all with same result. Very frustrating.


#5

Although our web team informs me they have a fix, it may take a couple days to deploy it. With your permission, I can get your email from the administrator and reach out to you directly with a direct download link for Python and any other tool you need. Let me know.
Regards,
-Peter


#6

No problem. Feel free to contact me via e-mail. Thanks.

-Steve


#7

i’m stuck in this same loop for curl. tried ie, firefox & chrome - they all take me back to registration.


#8

Any news on this? I have just registered (several times) to dowload bash and find myself in the loop described here.


#9

Hi Peter,

would you please send me a direct download link for Bash 4.2.53. I have the same issues with the download like everybody else.


#10

Hi,

Please use this link. It is for a more recent version of Bash.
Regards,
-Peter


#11

Thanks. Can you provide a link for curl as well, as I am having the same problem with that.


#12

Here is a link for cURL


#13

Hi Peter - sorry to bug you but I am a little out of my comfort zone with
tar files and the like. I used gunzip on the .gz file and then tar -xf on
the resulting tar file. When I execute bash -version I get garbage:

/u/…/bin/bash -version

å+í-Â/ËÇ–ÎÁÊËÑ?>-----------ÊÁ%Á/ËÁ–Ñ----ÑÂ_-?øÁ>ÁÀÑÈÑ?>–ä?øÊÑÅÇÈ--ä-------ãÊÁÁ-ë?ÃÈÏ/ÊÁ-ã?Í>À/ÈÑ?>--ñ>Ä--<ÑÄÁ>ËÁ-å&<Î----å+í-å&<-ÎÁÊËÑ?>---?Ê-%/ÈÁÊ--ÇÈÈø-Å> Í-?ÊÅ%ÑÄÁ>ËÁËÅø%-ÇÈ_%---èÇÑË-ÑË-ÃÊÁÁ-Ë?ÃÈÏ/ÊÁ--?Í-/ÊÁ-ÃÊÁÁ-È?-ÄÇ/>ÅÁ-/>À-ÊÁÀÑËÈÊÑÂÍÈÁ-ÑÈ–èÇÁÊÁ-ÑË-+|-ï êê +èß–È?-ÈÇÁ-ÁÌÈÁ>È-øÁÊ_ÑÈÈÁÀ-Â`-%/Ï–#

(This is under the OMVS shell) Looks like some kind of UTF8/EBCDIC
conversion occurred that shouldn’t have, or didn’t occur that should have.

Any idea what I’ve done wrong?

Cheers.


#14

Hi Peter, I got the same loop problem when trying to download PYTHON on Z, Could you give me a direct link ? thanks


#15

Python 2.7.6: https://download-eu.rocketsoftware.com/ro2/d/128FB3C01048499FB75174F54C115640


#16

Hi Peter, the above cURL link seems to be broken (HTTP 500). Could you provide a new one please.

TIA


#17

Here you go: https://download-eu.rocketsoftware.com/ro2/d/42360FA15F0C40BC8ED9C8864330AE41