Products Resources Support About Us

Rocket Software

Git and ISPF edit in 3.17

I am familiarizing myself with Rocket’s git port on z/OS and have a question relating to editing files that I have cloned. I am going to edit my cloned repo using ISPF option 3.17. However, every line in each of my files has a x’0D’ at the end of the line. This is a Line Feed character. The ISPF editor doesn’t really like embedded hex characters in source. You can’t insert code. When overtyping the cursor jumps over the hex character. There will be a number of other issues editing files using the ISPF editor that have embedded hex chars.

Generally in ISPF Edit in 3.17 the editor treats files in a similar way to record based members in say 3.4. There are no x’0D’ appended. This may have an issue if the USS files are transferred somewhere else for processing but that is a different topic

The only options I can see with my .gitattributes that relate to this area is to use *** text=auto eol=lf** to try and control the use of crlf. Now whilst I am also having problems with this not working as I expect, that is a different story for another post.

Is this the expected behaviour, to have to use ISPF edit with files that have x’0D’ line feed characters? Or did I do something wrong.

Update : Today, I am cloning the same projects as yesterday and there are no x’0D’ characters at the end of each line. Curious.

I don’t have that issue; you could also try ISHELL to see if it appears there.