Products Resources Support About Us

Rocket Software

Git and https repositories

Hi, thanks for producing the ports for these tools! We installed our Rocket tools into /usr/local/rocket/** and I’m hitting an issue with git and https remote repositories. Here’s an example error:

-bash-4.2$ _BPXK_AUTOCVT=ON GIT_EXEC_PATH=/usr/local/rocket/libexec git clone https://github.com/my/project
Cloning into ‘project’…
warning: templates not found /rsusr/rocket/share/git-core/templates
fatal: Unable to find remote helper for ‘https’

I can not seem to get https git cloning working, is it a known issue? I have tried with and without the GIT_EXEC_PATH override which seems to be a standard way of overriding the location of the git libexec path. Please assist, thanks!

-J

z/OS git only supports SSH at this time. Please set up key pairs to use git. Then you will be fine.
Best,
-Peter

Is this any problem download files from Rocket Download page? Nothing’s happening when I try to click and download.

Hi,

Please, look at the first post in this topic. Download page was moved into RocketCommunity.

Just re-read the release notes and http/https is still not supported. Is there a reason for this? Are there any plans to add http/https support?

I ask because my organization is planning on using git for all mainframe development. The majority of our mainframe developers are not familiar with the CLI or Git. Most have not even logged in to USS.

http/https support would mean one less administrative task for our developers to do, especially since for many of them this is a huge shift.

We do want to add client side http support, but this is not yet scheduled. Use of z/OS git as a server is not currently a priority.

I don’t understand why there would be a substantial difference between the current client side ssh support and http support; once the ssh key is configured on the client and server sides (a one-time setup step), there’s no difference in the way git treats an ssh vs. http remote. The fetch/pull/push commands are identical.

Generation of the ssh key pair can be automated with a script; we could help you with that.

We already have a script that generates the key-pair and displays the user’s public key for them to add to whatever remote repo they choose to use.

You are right there is not much difference after the first time setup. We can and are working with the client side ssh just fine. It’s not as though our developers will be unable to use SSH, current feedback is that client side http support is more convenient and will make the on-boarding process that much quicker, especially with the number of mainframe developers we have (150+).

If you are using GitHub, here is a helpful link on this topic: https://help.github.com/articles/adding-a-new-ssh-key-to-your-github-account/#platform-linux

We are having the same issue, doing a clone from our bitbucket repo to USS. Is this an SSH key pair generation issue?

ZOS1:/u/zrik/repo1>git clone https://local.bitbucket.url.se/repo1/repo1.git
Cloning into ‘repo1’…
warning: templates not found /rsusr/ported/share/git-core/templates
fatal: Unable to find remote helper for 'https’