Products Resources Support About Us

Rocket Software

Error while pushing code to bitbucket Public Repo using Rocket git from Z/OS

We are using Rocket git Client on Z/OS version 2.14. For timebeing we made our repos as Public so that we can clone without credentials while we setup https or ssh clone. Now when we are trying to push back changes that we made to repository, we get following error. Can anybody help why we are getting this error?

fatal: could not read Username for ‘http://testbitbucket.test.net’: EDC5137I Inappropriate I/O control operation.

Please also note that we have tried by setting user name as well and getting same error.

Thanks and Regards,

Danish.

Hi DKA,

Can you give us more detailed information about your issue…

  1. Git Configuration file
  2. Exact commands which gives this error
  3. env | sort
  4. git --version

One more thing:
Can you also try your failed scenario on other system and git (Linux or Windows) to make sure it’s a z/OS problem

Thanks,
Alexander

Hi Alax,

  1. I’m not sure about git configuration file on USS path. Can you please share where we can find that? I tired on /etc/gitconfig but unable to file.
  2. Its git push command thats is giving error. So we are trying to push back changes that we made to local git repo to bitbucket after commiting.
  3. Please find attachment for list of env variables for user.
  4. We are using Rocketsoftware git version 2.14.4_zos_b09

Let us know if you need anything else from our side.

Regards,
Danish

Hi DKA

What about:

Can you also try your failed scenario on other system and git (Linux or Windows) to make sure it’s a z/OS problem

command to check git config:

git config --list --show-origin

Thanks

Hi,

On windows/linux its working fine. Giving error only on Z/OS.
Also, Please find below output. Note that for security reason some dummy values placed like username, email and URL.

git config --list --show-origin
file:/u/omvsdflt/.gitconfig user.name=abc1111
file:/u/omvsdflt/.gitconfig user.email=dummyEmail@test.xyzdomain
file:/u/omvsdflt/.gitconfig core.editor=vim
file:.git/config core.repositoryformatversion=0
file:.git/config core.filemode=true
file:.git/config core.bare=false
file:.git/config core.logallrefupdates=true
file:.git/config remote.origin.url=‘http://testbitbucket.test.net/git/scm/testproject/testproject-test-cbl.git
file:.git/config remote.origin.fetch=+refs/heads/:refs/remotes/origin/
file:.git/config branch.develop.remote=origin
file:.git/config branch.develop.merge=refs/heads/develop

Regards,

Danish

Hi DKA,

A few more things:
You mentioned about attachment on previous msg, but probably forgot to attach it.
We also want from you exact commands, ideally full scenario to be able to reproduce this failure on our site.
Which software did you use to deploy your http git server
Thanks,
Alex

Hi Alex,

The exact command that we are using is: ( For security reason, I put duummy URL).

git clone -b develop http://mygiturl.git

Please note we used both http and https and getting same error.
The attachment contained user enviornment variable list that I already shared in my last post.
We are using Attlassian Bitbucket as repository Server and Rocket Software git as client on Mainframe.

Regards,

Danish

Hi Danish,

Unfortunately nowhere in this thread there’s a list of your environment variables. So far we’ve only received the ‘git config’ - which looks good and very similar to what we have on our system. Back on Feb 27, you said

Please find attachment for list of env variables for user.

However, we don’t see any attachments in this post. Would you be able to attach it again, or maybe just copy into a forum message?

Here’s why we still need it. Certain environment variables affect Git when it’s doing ‘push’, especially if it’s looking up for credentials - and judging by the error message, this is exactly what seems to be happening at your site. Seeing your environment variables might help us recreate the issue or analyze the corresponding pieces of code.

Thanks,
Vladimir

1 Like

Hi Vladimir,
Sorry just realized that its complete environment variables of user not only for git. So Please find them below.
RSE_HLQ=SYS3.EXPLOR31
rse_C=-- startup argument
rse_T=-- default
MAIL=/usr/mail/RSED
rse_U=-- set in envvars file
PWD=/u/TESTUSER
_CMDSERV_CONF_HOME=/etc/zexpl
JAVA_PROPAGATE=NO
RSE_LL=1
PATH=/pp/rocketsw/git/bin:/pp/db2/db210/jdbc/bin:/bin:/usr/sbin:/pp/java/J8.0_64/bin:.:/pp/PortedTools/bin:/pp/PortedTools/rocketsw/gzip/bin:/usr/lpp/ixm/IBM/xml4c-5_7/bin
RSE_HOME=/pp/zexpl/v3r1
TMPDIR=/tmp
rse_H=-- based on startup script location
_RSE_SERVER_CLASS=org.eclipse.dstore.core.server.Server
_EDC_PTHREAD_YIELD=-2
SHELL=sh
RSE_VERSION=3.1.1.0
JCC_PATH=/pp/db2/db210/jdbc
CGI_ISPDEBUG_MIN=true
_RSE_UMASK=RWX.N.N
DAEMON_LOGPATH=/var/zexpl/logs/server
_CEE_DMPTARG=/tmp
RSE_LIB=/pp/zexpl/v3r1/lib
_CEE_RUNOPTS=ALL31(ON) HEAP(32M,32K,ANYWHERE,KEEP,) TRAP(ON)
GSK_PROTOCOL_TLSV1_1=ON
_BPX_SPAWN_SCRIPT=YES
GSK_PROTOCOL_TLSV1_2=ON
RSE_CFG=/etc/zexpl
RSE_DSN_SFEKPROC=SYS3.EXPLOR31.SFEKPROC
_=/bin/env
CLASSPATH=/pp/db2/db210/jdbc/classes/db2jcc.jar:/pp/db2/db210/jdbc/classes/db2jcc_license_cisuz.jar:.:/pp/java/J8.0/lib
_RSE_PORTRANGE=8108-8118
OLDPWD=/u/TESTUSER
_BPXK_SETIBMOPT_TRANSPORT=TCPIP
JAVAHOME=/pp/java/J8.0_64
LOGNAME=RSED
GSK_PROTOCOL_SSLV3=OFF
STEPLIB=NONE
rse_TEMP=/tmp/rsed.sh.65588
_RSE_JMON_PORT=6715
rse_L=-- default
LANG=C
LIBPATH=/lib:/usr/lib:.:/usr/lpp/ixm/IBM/xml4c-5_7/lib
_RSE_ISPF_OPTS=&SESSION=SPAWN
_RSE_RSED_PORT=4035
rse_P=-- startup argument
_RSE_JAVAOPTS= -Xms128m -Xmx512m -Ddaemon.log=/var/zexpl/logs -Duser.log=/var/zexpl/logs -DDSTORE_LOG_DIRECTORY= -Dmaximum.threads=600 -Ddisable.classification=true -Dldap.server.address= -Dldap.server.port= -Dldap.ptc.group.name.suffix= -DISPF_OPTS=’&SESSION=SPAWN’ -DA_PLUGIN_PATH=/pp/zexpl/v3r1/lib -DDSTORE_INITIAL_SIZE=0 -DDSTORE_MAX_FREE=0 -DDSTORE_SPIRIT_ON=true -DSPIRIT_EXPIRY_TIME=90 -DSPIRIT_INTERVAL_TIME=6 -DDSTORE_KEEPALIVE_ENABLED=true -DDSTORE_KEEPALIVE_RESPONSE_TIMEOUT=60000 -DDSTORE_IO_SOCKET_READ_TIMEOUT=180000 -DRSECOMM_LOGFILE_MAX=0 -Djob.monitor.port=6715 -Dlock.info.timeout=10000 -Dlow.heap.usage.ratio=15 -Dmaximum.heap.usage.ratio=40 -Dcom.ibm.cacheLocalHost=true -Dfile.encoding=Cp1047 -Dconsole.encoding=Cp1047 -showversion -DRSE_VERSION=3.1.1.0
_CMDSERV_WORK_HOME=/var/zexpl
_BPX_SHAREAS=YES
CGI_ISPCONF=/etc/zexpl
RSE_PORT=4035
XERCESROOT=/usr/lpp/ixm/IBM/xml4c-5_7
file=rse.final.env
HOME=/u/TESTUSER
_CMDSERV_BASE_HOME=/usr/lpp/ispf
_RSE_POOL_SERVER_CLASS=com.ibm.etools.zos.server.ThreadPoolProcess
CGI_ISPHOME=/usr/lpp/ispf
CGI_ISPWORK=/var/zexpl
_RSE_DAEMON_CLASS=com.ibm.etools.zos.server.RseDaemon
_RSE_SAF_CLASS=/usr/include/java_classes/IRRRacf.jar
JAVA_CODEPAGE=Cp1047
CURRENT_DIRECTORY=/DMT1/etc/zexpl/
JAVA_HOME=/pp/java/J8.0_64
_RSE_LOG_LEVEL=1
_RSE_SERVER_TIMEOUT=120000
TZ=MEZ-1MESZ,M3.5.0/02:00:00,M10.5.0/03:00:00
_BPX_BATCH_SPAWN=YES
MANPATH=/usr/man/%L
NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/%L/%N.cat
GSK_PROTOCOL_TLSV1=ON
IBM_JAVA_COMMAND_LINE=java -Xms128m -Xmx512m -Ddaemon.log=/var/zexpl/logs -Duser.log=/var/zexpl/logs -DDSTORE_LOG_DIRECTORY= -Dmaximum.threads=600 -Ddisable.classification=true -Dldap.server.address= -Dldap.server.port= -Dldap.ptc.group.name.suffix= -DISPF_OPTS=&SESSION=SPAWN -DA_PLUGIN_PATH=/pp/zexpl/v3r1/lib -DDSTORE_INITIAL_SIZE=0 -DDSTORE_MAX_FREE=0 -DDSTORE_SPIRIT_ON=true -DSPIRIT_EXPIRY_TIME=90 -DSPIRIT_INTERVAL_TIME=6 -DDSTORE_KEEPALIVE_ENABLED=true -DDSTORE_KEEPALIVE_RESPONSE_TIMEOUT=60000 -DDSTORE_IO_SOCKET_READ_TIMEOUT=180000 -DRSECOMM_LOGFILE_MAX=0 -Djob.monitor.port=6715 -Dlock.info.timeout=10000 -Dlow.heap.usage.ratio=15 -Dmaximum.heap.usage.ratio=40 -Dcom.ibm.cacheLocalHost=true -Dfile.encoding=Cp1047 -Dconsole.encoding=Cp1047 -showversion -DRSE_VERSION=3.1.1.0 com.ibm.etools.zos.server.ThreadPoolProcess 120000 3 4 5 6
DAEMON_PORT=4035
RSE_LOGS=/var/zexpl/logs

Regards,

Danish

Hi Danish,

So far we’ve been unable to recreate your issue in-house. Unfortunately your environment variables didn’t give us any clues, so we’d like to get a bit deeper diagnostic on your end. Can you please try to run ‘git push’ with tracing enabled like this?

GIT_TRACE=1 GIT_TRACE_SETUP=1 GIT_TRACE_PACKET=1 git push whatever-push-arguments-you-need

This should give quite a verbose output in the terminal; please copy-paste or attach it here.

Thanks,
Vladimir