Products Resources Support About Us

Rocket Software

Error when executing change_pwd_perl.sh

I’m installing Perl under USS on z/OS 2.2 to support Python for a RedHat Ansible PoC. Everything was going swimmingly until I tried to run ./change_pwd_perl.sh, during which I received a fail for the file …/lib/perl5/5.24.0/os390/perllocal.pod (output from the script is attached).

I looked in the directory and the perllocal.pod file wasn’t there. Is this normal, or am I missing something?change_pwd_perl_sh_output.docx (12.2 KB)

Hello - sorry no solution here yet but I wanted to say that I am experiencing the same thing. All files were successful except for perllocal.pod.

Hi! Just wanted to update that I googled this a bit and it sounds like perllocal.pod customarily contains locally-installed modules not included with standard distribution. If that’s the case then the fact that this file is missing may be OK. I have proceeded without it for now anyway!