Products Resources Support About Us

Downloading Rocket z/OS Open Source Languages and Tools


#41

Hello Rocket Software,

I retried the process for downloading PHP again, i.e., I completed the form requesting my name, etc. I received the Get your downloads" e-mail, which contains a line that has two links:

Download php-544, or access all z/OS Open Source Tools.

(where “php-544” is one hyperlink and “access all z/OS Open Source Tools” is another).
Clicking on the “php-544” link does nothing but open a blank page (about:blank). If I look at the actual e-mail text there is no link in the e-mail source. If I click on the “access all z/OS Open Source Tools”, I actually get a Web page, however, all of the “Loading …” icons are not selectable.

I was able to download PHP via the link pfandel supplied in entry above. However, now I’m looking for PERL and CURL, Can you supply functioning download links for those products in this forum until whatever is wrong with the process is corrected ?

Thanks


#42

Sorry for the troubles. I am assured that our auto download link generation code is now working again. Please try again.


#43

Hi, I have registered and received the email from portedtools.

However, the download link is not an actual ‘active’ link – so I am provided no way with actually downloading the tools:

I am interested in downloading bash.

So it seems my problem is similar to mountie1 - except I don’t actually get a link on the ‘Download’ text.


#44

Hello Rocket Software,
I retried downloading PERL and CURL and both download processes worked without any problem.
Thanks for resolving this issue,
Mark Jackson,
Royal Canadian Mounted Police (RCMP).


#45

Peter, I’m in the same register / download / register loop as described elsewhere. I’m trying to download the latest perl 5.22.0, I used the link that I was sent today via e-mail, and when I go to the web page from the e-mail and click on the download button, it takes me right back to the “register for free tools” page. I’ve tried 2 different browsers. This has been going on (intermittently) since this site has existed, and it’s maddening (you know the line about “going crazy is a much shorter trip for some than for others”, right?). What about making it mandatory to join the Software Forum, and just key the download authorization off of those credentials? If you’re trying to track who downloaded what and when, this should give it to you. Also, it would be helpful if the full version of the file (i.e. like “perl-5.22.0_b0004.160229.tar.gz” was available right on the download page, that way you could tell just by looking at the full file name whether there was a newer copy of the file to download than the one you have…

In the meantime, any bypass available for the problem?

Thanks,
-Mike


#46

the download loop problem still exists, could you give the download link for Python?


#47

Python 2.7.6: https://download-eu.rocketsoftware.com/ro2/d/128FB3C01048499FB75174F54C115640


#48

same Looping prob for curl download.


#49

I’m also in the same register / download / register loop. Tried to download Perl, DiffUtil, Git. I hope it resolve in the near future.


#50

For those stuck in the endless registration loop, I have a couple of questions so we can track down where the problem is:

  1. Are you using the same browser to register as you are using to access the download URL in the email?
  2. Do you have cookies enabled?
  3. There are 2 links in the email, the first is a direct download and the other goes to a web page to download all the tools. Does the direct download link in the email work?

Thank you,
Chris


#51

Hello Chris.
The answer for first and second questions are yes.
For the third question, its my fault that i didn’t recognize the direct download link for Perl. Now i tried and it worked.
Besides, the link for all downloads is also works now. You corrected something or more probably I missed something, I don’t know but it is all ok now.

Thank you very much for your fast response and attention.


#52

I just registered to download perl and did not see the download link in the email in Outlook. All it showed was
Download , or access all z/OS Open Source Tools.
However if you save the email and look at the source you will see the download link after the word Download

Al


#53

Which version of perl did you try to download?


#54

perl-5.22.0_b0005.160429.tar.gz


#55

For Perl 5.22 (EBDCI only) you can use this URL.
For Perl 5.24 (supports z/OS enhanced ASCII) you can use this URL.


#56

I am trying to download OpenSSL from link given. I am unable to download it using link I received after registering. I did try another tool, Python, and it worked without issue. Is there an alternative link for downloading OpenSSL?


#57

Try this please: https://download-eu.rocketsoftware.com/ro2/d/1B5CFF987BF64DAD872A54D72D5B3ACE


#58

I’m trying to download and untar gzip-1.6-edc_b0005.160229.tar Like some other people above, when I try to untar it, I get the error:

tar: checksum error on tape (got 42e5, expected 0)

Using the:

od -t x1 < gzip-1.6-edc_b0005.160229.tar | head

command suggested above, I get:

0000000000 4B 61 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0000000020 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
*
0000000140 00 00 00 00 F0 F0 F0 F7 F7 F5 40 00 F0 F0 F3 F1
0000000160 F4 F6 40 00 F0 F0 F0 F7 F6 F5 40 00 F0 F0 F0 F0
0000000200 F0 F0 F0 F0 F0 F0 F0 40 F1 F2 F6 F6 F4 F7 F5 F7
0000000220 F5 F6 F6 40 F0 F1 F1 F1 F1 F3 40 00 F5 00 00 00
0000000240 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
*
0000000400 00 A4 A2 A3 81 99 00 F0 F0 D7 C4 D2 E4 E9 D4 00
CEE5213S The signal SIGPIPE was received.

Compared to what I’m supposed to be getting (see above), this looks like it has gone through an ASCII -> EBCDIC IMB-1047 conversion. I uploaded the tar file to z/OS (from cygwin under Windows) using scp, which only supports binary file transfers (and presumably knows nothing about EBCDIC), so it seems likely that the unwanted ASCII -> EBCDIC IBM-1047 conversion happened on the receiving z/OS end of the scp transfer. (I have also confirmed with tar -tvf that the cygwin copy I was scping from is undamaged.) ls -alT shows that the z/OS received copy is untagged (I experimented with retagging it as binary or IBM-1047 text, but it didn’t help). Is there some z/OS configuration setting that I can change to disable this unhelpful behavior (automatically doing an ASCII -> EBCDIC conversion on files being received by scp)?


#59

Applying:

iconv -f IBM-1047 -t ISO8859-1 gzip-1.6-edc_b0005.160229.tar > gzip-1.6-edc_b0005.160229.new.tar

undoes the corruption and yields a usable new.tar file, but this is annoying to have to do every time I upload a file.


#60

Note, many of the posts on this topic relate to the old way to download Rocket’s z/OS open source products, and are no longer relevant with the introduction of a new system which is easier to use. The original posting has been edited to describe the new system.