Products Resources Support About Us

Downloading Rocket z/OS Open Source Languages and Tools


#1

All of the Rocket z/OS ports of open source languages and tools are available for download from the Rocket Community website downloads page.

Log in to the Rocket Community here: https://my.rocketsoftware.com/RocketCommunity/RCLogin

If you do not have an account, you can request one here at no cost.

All downloads are meant to be unpacked on z/OS. However, most people first download to a PC and then transfer to z/OS (e.g. via SFTP) for unpacking. Be sure to use binary mode when transferring!

Other forum posts cover unpacking, version and README info, and installation generalities.


Git and https repositories
#2

#3

Downloads seem to be corrupted. I’ve downloaded several of the tools, then binary FTP’d (also tried SFTP) to my system. All fail to decompress. Example:

$ tar -zxvf bash-4.2_b0004.160229.tar.gz
tar: decompress: FSUM6636 not in compressed format

Also, gzip fails to untar:

$ tar -xovf gzip-1.6-edc_b0005.160229.tar
tar: checksum error on tape (got 28c8, expected 0)


#4

Sorry for screw-up. New downloads in place. However, new bash is not downloading. Seems to be a problem with our download web infrastructure affecting only this tool.


#5

Web download infrastructure problem also now fixed. All tools including bash have been re-uploaded and download tested.


#6

Thanks. They work now.


#7

I am trying to download the tools and I am getting the same problems listed here. Were the products uploaded again recently?


#8

Hi Patti,
Did you read this other post? It may help.

http://forum.rocketsoftware.com/t/unpacking-tool-distributions/211

#9

Yes, I read the post. I also read the post about z/OS 1.13. The tar is not working for gzip either.


#10

I took the time to do an end-to-end test just now. Requested download, got email, clicked link, downloaded gzip 1.6 to my PC, transferred from PC to z/OS USS in binary mode, once in USS, I applied “tar -xovf” command to unpack gzip. All worked correctly. Also sucessfully tested gunzip to unpack bash download downloaded and transferred in the same way.

Did you use binary mode when transferring the distributions into USS?


#11

Yes, I even tried it with two different programs. I will start over and see how it goes.


#12

Hello -

I have tried to obtain the download links a couple of times with no success. Due to aggressive SPAM filtering, that is beyond my control, it seems that I am unable to receive an email from portedtools@rocketsoftware,com (although noreply@rocketsoftware.com worked fine). This is likely due to the email service provider that is sending the email being flagged as a source of undesired email and being blocked. Unfortunately, this is not the first time I have had this problem. Is there an alternate method to obtain the download links?

Thank you.


#13

I am still getting the same error on the gzip download:

-rw-r–r-- 1 PNEUMAN OMVSGRP 999928 Apr 12 15:09 gzip-1.6-edc_b0005.160229.tar
PNEUMAN(/usr/local)$ tar -xovf gzip-1.6-edc_b0005.160229.tar
tar: checksum error on tape (got 42e5, expected 0)

I am downloading from the web page, using Ipswitch WS FTP Pro 12.4. The transfer mode is set to binary. I am transferring to a z/10 bc running z/OS 2.1.0 (SPLevel 7.2.1). Is it possible to ftp the files directly to the mainframe?


#14

Hi Patti,

I am sorry you are having troubles. Below is a command I ran to display the first few bytes of the tar as it should look. If you downloaded the same tar, run this command, and see a different set of bytes, then somewhere along the way the tar got corrupted. I used Firefox 45.0.1 to download to my PC and transferred to USS using WinSCP 5.7.6 (in binary mode).

od -t x1 < gzip-1.6-edc_b0005.160229.tar | head

0000000000 2E 2F 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0000000020 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
*
0000000140 00 00 00 00 30 30 30 37 37 35 20 00 30 30 33 31
0000000160 34 36 20 00 30 30 30 37 36 35 20 00 30 30 30 30
0000000200 30 30 30 30 30 30 30 20 31 32 36 36 34 37 35 37
0000000220 35 36 36 20 30 31 31 31 31 33 20 00 35 00 00 00
0000000240 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
*
0000000400 00 75 73 74 61 72 00 30 30 50 44 4B 55 5A 4D 00


#15

Hi Fred, At present there is no other download mechanism nor to my knowledge plans for alternatives.


#16

Fred,
I had my co-worker whitelist portedtools@rocketsoftware.com. That seems to have worked. I hope this helps.


#17

Well, I figured out my problem. I was using sftp in WinSCP to transfer the files. I changed it to an ftp connection and the files transferred correctly. On to the install. Thanks for all your help.


#18

You are most welcome Patti


#19

Hello,

I have received following download link, but when I opened it with firefox, the “expired” message was prompted. How can I fix this problem? Thanks.


#20

This appears to be a new problem. I just reproduced it myself. I have assigned this to our web team to resolve. Sorry for the inconvenience and thanks for letting us know.
-Peter