Products Resources Support About Us

Rocket Software

ActiveX component can't create a object:bzwhll.whllobj

Hi Sir,

Your help is very much appreciated. I was struggling from week. I have sample VB script code that have created bzwhll object that will open session & login into bluezone mainframe. The sample code is working from command line
system32>cscript filename.vbs. (It create object, opensession,login to bluezone)
Same script will fail from below run command
syswow64>csript filenam.vbs

The same script I added to .hta file and ran it from win10 OS. I’m receiving “ActiveX component can’t create object bzwhll.whllobj”. It fails at second line in code give below.

Dim Host
Set Host = CreateObject( “BZWhll.WhllObj” )
Retval=Host.OpenSession(0,1,"",5,1)

FYI: I have done below process:

  1. Window10 64-bit
  2. Bluezone v7.1 - Installed 32-bit, 64-bit (Initially installed 64-bit and it not worked. So 32-bit also installed)
  3. I registered the bzwhll.dll with 32-bit & 64-bit version using System32>regsvr32 filename.dll
  4. The same code will work in windows7 (v5.2) with .hta/.vbs. problem with windows10.
  5. Services->ActiveX is running state.
    If i run from .hta it got failed at 2nd line. ActiveX error. But the script is running through .vbs. Is there anything to add in .html file.?

Thank you in Advance.

You may still have two versions of Bluezone installed and registered - but only one of the Bzwhll.dll files will be active. Look in the HKEY_USERS*youruserid*\Software\BlueZone
You should fully uninstall BlueZone, then install the BZ 7.1 for 64 bit desktop version.

by default 64bit windows will run script using 64bit cscript.exe. Open cmd and go to “C:\Windows\SysWOW64” for 32bit programs and “C:\Windows\system32” is for 64bit code - see: https://www.howtogeek.com/326509/whats-the-difference-between-the-system32-and-syswow64-folders-in-windows/

Thanks for your reply. It’s was useful and very much happy for responding. It’s really positive hope.

Still i had same issue. “ActiveX component can’t create a object:Bzwhll.whllobj”. What are possibility of occurring of this error.?

  1. Do i need to update any IE settings.? Like enable ActiveX.

I have Register the Bluezone 64-bit bzwhll.dll with system32>regsrv32.
If i run with sample code inside a .vbs file it is creating the connection using
cmd:system32>cscript filename.vbs
If i run it from .hta then it throw ActiveX error.

FYI - If i run .vbs file with cmd: syswow64>cscript filename.vbs then it throw ActiveX error. Is that some fishy right.? Any problem in running .hta file. The .hta running .vbs script files using syswow64 instead of system32.
Is there any way to run the .vbs script with system32.? I mean any setting to add in .hta file.

If possible please share any mandatory settings that need to be update for creating object bluezone 7.1.6 (64-bit) in windows10 machine.?

Your help is very much needed. I will keep updating.
Thanks.

Any update on this? I’m also having the same issue with my VBA code giving a runtime error activex can’t create object on my create object code line.

Everything was working flawlessly, and then we migrated from windows 7 to windows 10. I had to update the code on excel with PtrSafe on my declaration lines and LongPtr for all my Long data types, which resolved that incompatibility issue - but now i’m receiving this activex runtime error 429.

bluezone 7.1, reference is active and selected, and I registered the .dll in both System32 and SysWow64

Please let me know if you have resolved or anyone else has any additional feedback to resolve

Thanks,
Mike

Hi Mikey85
There are typically one of two reasons that this error can occur:

  1. The BlueZone Extra!-compatibility objects(Bzextr.dll) from the Migration Toolkit are not installed and registered on the client machine.
    Install and/or re-register the Bzextr.dll file in the BlueZone Program directory by running a DOS prompt As Administrator and execute the command, for example: Regsvr32 “C:\Program Files (x86)\BlueZone\7.1\Bzextr.dll”

Or,

  1. The Microsoft Office version installed is 64-bit, but the BlueZone application and objects are 32-bit only.
    Uninstall Microsoft Office 64-bit and re-install Office 32-bit. Or, uninstall BlueZone (32-bit) and install BlueZone v7.1 (64-bit).

You can double-check that the registration has worked - in your registry
Look for
HKEY_CLASSES_ROOT\BZWhll.WhllObj\CLSID
and
HKEY_CLASSES_ROOT\BZWhll.WhllObj.7.1\CLSID

if your installation worked then they should be pointing to the same class-id, for example for 32 bit VBA working with 32bit BlueZone 7.1

HKEY_CLASSES_ROOT\Wow6432Node\CLSID{4EB971C3-00D0-11D5-903D-00105AABADD3}\InprocServer32
This should have a value showing the path to the bz dll for example:
c:\programdata\bluezone\7.1\bzwhll.dll